Simple Configuration Load Balancing ( 2 line 1 router)

1. Setting Ip address
/ip address
add address=192.168.0.254/24 network=192.168.0.0 broadcast=192.168.0.255
interface=Local comment="Link to Local Lan" disabled=no
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.255
interface=speedy1 comment="Link to Modem 1" disabled=no
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255
interface=speedy2 comment="Link to Modem 2" disabled=no



2. Setting manggle untuk konsep NTH dan mark packet
/ip firewall mangle
add chain=prerouting in-interface=Local connection-state=new
nth=1,2,0 action=mark-connection new-connection-mark=link1
passthrough=yes comment="Mark Nth for link 1" disabled=no
add chain=prerouting in-interface=Local connection-mark=link1
action=mark-routing new-routing-mark=link1 passthrough=no
comment="" disabled=no
add chain=prerouting in-interface=Local connection-state=new
nth=1,2,1 action=mark-connection new-connection-mark=link2
passthrough=yes comment="Mark Nth for link 1" disabled=no
add chain=prerouting in-interface=Local connection-mark=link2
action=mark-routing new-routing-mark=link2 passthrough=no
comment="" disabled=no

3. Nat tables untuk Link1 and link 2
/ip firewall nat
add chain=srcnat connection-mark=link1 action=src-nat to-addresses=
192.168.1.2 to-ports=0-65535 comment="Masquee Nat Link 1" disabled=no
add chain=srcnat connection-mark=link1 action=src-nat to-addresses=
192.168.2.2 to-ports=0-65535 comment="Masquee Nat Link 2" disabled=no

4. Ip routing for link 1 and 2
/ ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10
routing-mark=link1 comment="Link To modem1" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.2 scope=255 target-scope=10
routing-mark=link2 comment="Link To modem1" disabled=no
add dst-address=0.0.0.0/0 gateway=192.168.2.2 scope=255 target-scope=10
comment="Default routing" disabled=no <<-- this default routing



sumber